v2fly(V2Ray)近期新版本升级后不能使用的问题解决

【美博翻墙】v2fly(V2Ray)近期几个版本核心core代码变动较大,好些网友在升级后出现诡异的不能使用问题,报错:

基础连接已经关闭:发送时发生错误
或
远端服务器传回一个错误:(503)服务器无法使用

目前不知道问题出在哪里?未见官方释出解决方案,如果你已经升级出现了不能使用的这些问题,不用急,或者没有升级的旧版使用者如何应对,下面是美博给出的解决办法。

如果网友有更好的解决办法,也请留言分享。

一、哪些新版出现问题

美博经过逐版安装测试,近期几个版本

2021年12月6日 v4.44.0
2021年5月1日 v4.38.3
2021年3月8日 v4.35.1

在升级后,就会出现上述报错,v2fly(V2Ray)突然在升级后不能使用。

而其之前的版本就没有问题,如:

2021年1月7日 v4.34.0
2020年11月1日 v4.32.0
2020年10月24日 v4.31.3
2020年10月11日 v4.31.0
2020年9月18日 v4.28.2
2020年9月2日 v4.27.5
……

二、解决办法:旧版如何升级到 v4.34.0版

如果你的v2fly(V2Ray)已经按照美博教程安装很久了,不要升级到最新版本,目前最多升级到 v4.34.0版

1、查看自己的v2fly(V2Ray)版本

前文【如何更新 v2fly(V2Ray)版本】所述:

查看已安装版本

SSH登入你的VPS服务器后,输入如下命令来查看以前安装的版本,
输入:

v2ray -version

会显示出版本号:
~# v2ray -version
V2Ray 4.34.0 (V2Fly, a community-driven edition of V2Ray.) Custom (go1.15.5 linux/amd64)
A unified platform for anti-censorship.

如果是 2021年1月7日 v4.34.0 (含)之前的版本,目前最多升级至 v4.34.0。

据美博的测试,升级至2021年3月8日 v4.35.1(含)以上,及目前的最新版2021年12月6日 v4.44.0,将出现错误:

基础连接已经关闭:发送时发生错误
或
远端服务器传回一个错误:(503)服务器无法使用

2、指定版本升级

以前的升级方法,都是使用安装最新版本的指令,将前文:

如何更新 v2fly(V2Ray)版本 - 美博园

但是目前遇到了v2fly(V2Ray)的版本问题,那么,我们需要执行“指定版本”的安装升级。

原则:如果是 2021年1月7日 v4.34.0 (含)之前的版本,目前最多升级至 v4.34.0

使用如下命令进行:

◆ SSH登入你的VPS服务器后,输入如下命令来升级安装指定版本,
输入:

bash <(curl -L https://raw.githubusercontent.com/v2fly/fhs-install-v2ray/master/install-release.sh) --version v4.34.0

注:v4.34.0 是版本号

◆ 安装完成后,输入启动指令:

systemctl enable v2ray
systemctl start v2ray

这样,v2fly(V2Ray)可以继续使用了,原设置不需变动。

三、已经升级到最新版本并出现问题的,退回到 v4.34.0之前的版本

比如,最近你升级到目前的最新版 v4.44.0,那么出现问题了,怎么办呢?

目前没有找到好的解决办法。可以退回到旧版来解决,据美博测试退回到 v4.34.0(含)之前的任何一个版本都可以,版本号如上面所述。

命令仍然是:

◆ SSH登入你的VPS服务器后,输入如下命令来升级安装指定版本,
输入:

bash <(curl -L https://raw.githubusercontent.com/v2fly/fhs-install-v2ray/master/install-release.sh) --version v4.34.0

注:v4.34.0 是版本号

◆ 安装完成后,输入启动指令:

systemctl enable v2ray
systemctl start v2ray

四、其他说明

1、如果你的系统升级到v4.34.0仍然出现上述问题,就继续往前退。

有网友说退回到 v4.27.5版可用,美博测试是v4.34.0(含)之前都可以,这个差异可能是使用的系统不同。

上述命令,只需要修改 4.34.0 这个版本号数字即可。

2、这个问题不是客户端的问题

据美博测试,这个问题不是客户端的问题。只要v2fly(V2Ray) core升级到那几个新版,无论客户端使用哪个版本都是一样的问题。

如果是v4.34.0(含)之前的版本,客户端如v2rayN,升级到目前最新版v425,或旧版,都可以正常使用。

原文链接:https://allinfa.com/v2fly-v2ray-upgrade-not-working-problem-solved.html
原文标题:v2fly(V2Ray)近期新版本升级后不能使用的问题解决 - 美博园
美博园文章均为“原创 - 首发”,请尊重辛劳撰写,转载请以上面完整链接注明来源!
软件版权归原作者!个别转载文,本站会注明为转载。

网 友 留 言

2条评论 in “v2fly(V2Ray)近期新版本升级后不能使用的问题解决”
  1. Cerva

    老师好,近期一直在找这个原因,终于找到了,赶紧上来告知各位一直为此困惑的朋友,其实很简单,把服务器和客户端配置里的“额外ID”改为0(原来是64)即可,具体请看这里:https://github.com/v2fly/v2ray-core/issues/1613
    【是2022年1月1日啟用了「VMess MD5 认证信息 淘汰机制」的問題。如欲解決,請參見https://www.v2fly.org/config/protocols/vmess.html#inboundconfigurationobject
    或 youtube視頻:https://www.youtube.com/watch?v=BmfKwDClFlk】
    麻烦老师更新一下网站内容。

  2. jason

    Thank you very much !
    十分感謝!

这里是你留言评论的地方


请留言


7 + 9 =
【您可以使用 Ctrl+Enter 快速发送】
Copyright © 2007 - 2022 , Design by 美博园. 版权所有. 若有版权问题请留言通知本站管理员. 【回到顶部】